OpenCore Legacy Patcher offre une prise en charge non officielle de Ventura pour les anciens Mac

[ad_1]

La mise à jour de macOS Ventura a mis fin à la prise en charge d’une large gamme de Mac Intel, y compris les modèles introduits en 2013, 2014, 2015 et 2016. Mais comme pour les anciennes versions de macOS, les développeurs indépendants ont intensifié la prise en charge non officielle de nombreux Mac qui ne recevoir plus de mises à jour. La version 0.5.0 du projet OpenCore Legacy Patcher a ajouté la prise en charge de Ventura pour les modèles Mac remontant à 2012, donnant aux personnes qui ne craignent pas un peu de bug la possibilité de garder leur Mac à jour avec de nouvelles fonctionnalités.

OpenCore Legacy Patcher (OCLP) est une émanation du chargeur de démarrage OpenCore qui se concentre sur le rajout de la prise en charge du matériel Mac plus ancien, au lieu de faire fonctionner macOS sur des PC génériques x86 « Hackintosh ». Parce qu’Apple a abandonné la prise en charge de tant de Mac de Ventura, la prise en charge de ce système d’exploitation sur ces machines plus anciennes a nécessité beaucoup plus d’efforts que les années précédentes, ce que nous avons déjà couvert.

Modèles Mac pris en charge par le projet OpenCore Legacy Patcher.

La liste de support officielle, illustrée ci-dessus, est similaire à celles de Mojave et Catalina, les premières versions de macOS à nécessiter un GPU compatible Metal. Le seul modèle de ce millésime non pris en charge actuellement est le Mac Pro 2013 « poubelle », qui rencontre des problèmes de démarrage liés au GPU qui sont toujours en cours de résolution. Les Mac plus anciens avec des GPU pré-Metal ne sont absolument pas pris en charge et l’accélération graphique (entre autres choses) ne fonctionnera pas sur ces Mac ; l’équipe travaille sur l’ajout de la prise en charge de ces anciens modèles, mais il est peu probable qu’ils fonctionnent aussi bien que les modèles compatibles avec Metal.

L’exécution de Ventura avec OCLP comporte des risques. L’équipe OCLP a également dressé une courte liste de bogues graphiques affectant les anciens Mac, principalement centrés sur l’encodage et le décodage vidéo, les DRM et les plantages occasionnels d’applications. Et vous devrez peut-être attendre que le projet OCLP soit mis à jour avant d’installer les futures mises à jour de Ventura, car ces mises à jour changeront parfois les choses d’une manière qui casse le chargeur de démarrage OpenCore ou les nombreux correctifs dont les anciens Mac ont besoin pour exécuter de nouveaux logiciels.

Ces anciens Mac peuvent également manquer certaines des mises à jour de sécurité proposées aux modèles plus récents. Les mises à jour officielles de macOS contiennent parfois un nouveau micrologiciel système et d’autres correctifs de bas niveau qui peuvent résoudre des bogues ou corriger des failles de sécurité ; Les Mac non pris en charge exécutant Ventura via le projet OCLP ne recevront pas ce type de correctifs.

Si vous souhaitez essayer OpenCore Legacy Patcher sur vos propres systèmes, la documentation la plus récente se trouve ici.

[ad_2]

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*